المحتوى عن 'docs'.



مزيد من الخيارات

  • ابحث بالكلمات المفتاحية

    أضف وسومًا وافصل بينها بفواصل ","
  • ابحث باسم الكاتب

نوع المُحتوى


التصنيفات

  • التخطيط وسير العمل
  • التمويل
  • فريق العمل
  • دراسة حالات
  • نصائح وإرشادات
  • التعامل مع العملاء
  • التعهيد الخارجي
  • التجارة الإلكترونية
  • الإدارة والقيادة
  • مقالات ريادة أعمال عامة

التصنيفات

  • PHP
    • Laravel
    • ووردبريس
  • جافاسكريبت
    • Node.js
    • jQuery
    • AngularJS
    • Cordova
  • HTML
    • HTML5
  • CSS
  • SQL
  • سي شارب #C
    • منصة Xamarin
  • بايثون
    • Flask
    • Django
  • لغة روبي
    • Sass
    • إطار عمل Bootstrap
    • إطار العمل Ruby on Rails
  • لغة Go
  • لغة جافا
  • لغة Kotlin
  • برمجة أندرويد
  • لغة Swift
  • لغة R
  • لغة TypeScript
  • ASP.NET
    • ASP.NET Core
  • سير العمل
    • Git
  • صناعة الألعاب
    • Unity3D
  • مقالات برمجة عامة

التصنيفات

  • تجربة المستخدم
  • الرسوميات
    • إنكسكيب
    • أدوبي إليستريتور
    • كوريل درو
  • التصميم الجرافيكي
    • أدوبي فوتوشوب
    • أدوبي إن ديزاين
    • جيمب
  • التصميم ثلاثي الأبعاد
    • 3Ds Max
    • Blender
  • نصائح وإرشادات
  • مقالات تصميم عامة

التصنيفات

  • خواديم
    • الويب HTTP
    • قواعد البيانات
    • البريد الإلكتروني
    • DNS
    • Samba
  • الحوسبة السّحابية
    • Docker
  • إدارة الإعدادات والنّشر
    • Chef
    • Puppet
    • Ansible
  • لينكس
  • FreeBSD
  • حماية
    • الجدران النارية
    • VPN
    • SSH
  • مقالات DevOps عامة

التصنيفات

  • التسويق بالأداء
    • أدوات تحليل الزوار
  • تهيئة محركات البحث SEO
  • الشبكات الاجتماعية
  • التسويق بالبريد الالكتروني
  • التسويق الضمني
  • التسويق بالرسائل النصية القصيرة
  • استسراع النمو
  • المبيعات
  • تجارب ونصائح

التصنيفات

  • إدارة مالية
  • الإنتاجية
  • تجارب
  • مشاريع جانبية
  • التعامل مع العملاء
  • الحفاظ على الصحة
  • التسويق الذاتي
  • مقالات عمل حر عامة

التصنيفات

  • الإنتاجية وسير العمل
    • مايكروسوفت أوفيس
    • ليبر أوفيس
    • جوجل درايف
    • شيربوينت
    • Evernote
    • Trello
  • تطبيقات الويب
    • ووردبريس
    • ماجنتو
  • أندرويد
  • iOS
  • macOS
  • ويندوز

التصنيفات

  • شهادات سيسكو
    • CCNA
  • شهادات مايكروسوفت
  • شهادات Amazon Web Services
  • شهادات ريدهات
    • RHCSA
  • شهادات CompTIA
  • مقالات عامة

أسئلة وأجوبة

  • الأقسام
    • أسئلة ريادة الأعمال
    • أسئلة العمل الحر
    • أسئلة التسويق والمبيعات
    • أسئلة البرمجة
    • أسئلة التصميم
    • أسئلة DevOps
    • أسئلة البرامج والتطبيقات
    • أسئلة الشهادات المتخصصة

التصنيفات

  • ريادة الأعمال
  • العمل الحر
  • التسويق والمبيعات
  • البرمجة
  • التصميم
  • DevOps

تمّ العثور على 4 نتائج

  1. أنهينا الجزء الأكبر من العمل على تقرير المبيعات في الدرس السابق وستكون مهمتنا في هذا الدرس إضافة بعض اللمسات السحرية والتشطيبات النهائيَّة لبدء استعمال التقرير. سنتعلم في هذا الدرس بعض التوابع الجديدة التي سنضيفها إلى تقرير المبيعات وسنعرِّج على موضوع حماية أوراق العمل والنطاقات أثناء مشاركة الملف مع الآخرين ثمَّ سنتعرَّف على كيفيَّة استعمال التنسيق الشرطي. دمج مجموعة من التوابع استعملنا في الدرس السابق القائمة المنسدلة لإدراج المنتج المُباع (حقل رقم المنتج والوصف) ولكن توجد حقيقةً طريقة أخرى متقدمة نستعمل فيها التوابع لاختيار وصف المنتج بالبحث عنه في جدول المخزون. التوابع التي سنستخدمها هي: التابع طريقة الاستعمال الوصف IFERROR IFERROR(value, [value_if_error]) يُرجع هذا التابع القيمة الأولى إن لم تكن خطأً، وإن كانت خطأ فيرجع القيمة الثانية إن كانت موجودة أو يرجع قيمة فارغة. يُستعمل للتحكم في ظهور الأخطاء في الخلايا. IF IF(logical_expression, value_if_true, value_if_false) يُرجع القيمة الأولى (value if true) إن تحقَّق التعبير المنطقي (logical expression) ويرجع القيمة الثانية إن لم يتحقق. ISNA ISNA(value) يُستعمل للتحقُّق إن كانت القيمة (value) هي خطأ ذو الرمز "#N/A" أي غير متاح أو متوافر (not available) أو لا يتوافر جواب للعمليَّة، ويُرجع العبارة "true" إن كانت القيمة هي خطأ من النوع السابق أو يُرجع العبارة "false" إن لم تكن خطأ. VLOOKUP VLOOKUP(search_key, range, index, [is_sorted]) يُستخدم للبحث العمودي، ومُدخلات هذا التابع هي: search_key: القيمة التي نبحث عنها. Range: المجال الذي نبحث فيه. Index: رقم الحقل الذي نريد جلب القيمة المقابلة للقيمة التي نبحث عنها في العمود الأول من المجال المحدَّد. is_sorted: إن كانت القيم في المجال المحدَّد مرتَّبة نضع "true" وإن لم تكن مرتَّبة نضع "false". قبل استعمال التابع دعنا نفعل شيئًا يسِّهل عملنا؛ سننتقل إلى ورق المخزون ونحدِّد جدول المخزون أي عمود رقم المنتج والوصف ثمَّ نضغط بزر الفأرة الأيمن ونختار “تعريف النطاق المحدَّد” ونعطي للنطاق المحدَّد عنوان “المنتجات” ثمَّ نضغط على “تم“؛ إن أردنا استعمال النطاق السابق في التوابع أو أي مكان فما علينا سوى كتابة اسمه. مزيَّة عنونة النطاق هي بقاء النطاق ثابت مهما تحركت الخليَّة أو نُسخت إلى مكان آخر في الجدول إذ إن لم يُثبَّت النطاق فسيتغير نسبة إلى تغير عنوان الخليَّة. نُدرج التوابع السابقة في الخليَّة E8 للبحث عن الوصف المقابل لرقم المنتج المُدخل في الخليَّة D8 في جدول المخزون وذلك كما موضح في الصورة. استعملنا أولًا التابع IFERROR لإظهار الرسالة التي نريدها إن وُجد خطأٌ ما لتجنب ظهور رموز لا نرغب بها؛ وضعنا في الدخل الأول التابع IF والدخل الثاني الرسالة “لم يُعثر على المنتج” لإظهارها في حال وجود أي خطأ. القيمة المنطقية للتابع IF هي التابع ISNA مع التابع VLOOKUP للتأكد من وجود القيمة التي نبحث عنا؛ إذا لم يجد التابع VLOOKUP ما يبحث عنه فسيُرجع الخطأ ‎#N/A وحينئذٍ سيُرجع التابع ISNA العبارة true أي يوجد خطأ وبالتالي يأخذ التابع IF القيمة الأولى وهي “لم يُعثر على المنتج”. أمَّا إن وجد التابع VLOOKUP القيمة التي يبحث عنها فسيرجع التابع ISNA القيمة false أي لا يوجد خطأ وبالتالي سيختار التابع IF القيمة الثانية وهي التابع VLOOKUP أي القيمة التي يرجعها هذا التابع وهي التي نبحث عنها في جدول المخزون. لاحظ أنَّنا استعملنا عبارة “المنتجات” للدلالة على عنوان جدول المخزون الذي نودُّ البحث فيه ويمكن استعمال النطاق مباشرةً مع الضغط على F4 لتثبيت عنوان النطاق. نسحب الخليَّة E8 إلى الخلايا السفليَّة لنسخ العلاقة وستكون النتيجة كما موضح بالصورة. إن وَجدت للوهلة الأولى أنَّ الأمر معقدٌ فجرِّب كتابة العلاقة السابقة بنفسك وأعد قراءة الشرح مرةً أخرى وستفهمها بالتأكيد. حماية الأوراق والخلايا انتهينا من إنشاء تقرير المبيعات وأصبح جاهزًا للاستخدام. سنشارك هذا الجدول مع العامل ليُدخل بيانات المنتجات التي يبيعها ولكن ماذا لو غيَّر قيم خلايا لا يحق له تغييرها مثل تغيير قيم جدول المخزون أو تغيير محتوى خليَّة الوصف التي تعذبنا كثيرًا حتى أنشأناها أو في محتوى الخلايا الأخرى بقصد أو بغير قصد؟! سنضطر هنا إلى حماية الأوراق أو الخلايا من عبث الأشخاص الذين نشاركهم ملفاتنا وسنعطي كلَّ شخص الصلاحيات المناسبة للتعديل على الخلايا والأوراق. نضغط على السهم الموجود بجانب ورقة المخزون ونختار “حماية الورقة” أو نختار من قائمة البيانات ← الأوراق والنطاقات المحميَّة وستظهر قائمة في الطرف الأيسر. نضع وصفًا لحماية الورقة ثمَّ نحدِّد إن كنا نريد حماية الورقة بأكملها أو نطاق محدَّد ضمن الورقة ثمَّ نحدِّد اسم الورقة وإن كنا نريد أن نستثني بعض الخلايا ليتاح تعديلها ثمَّ نضغط على “تعيين الأذونات“. يظهر لدينا خيارين؛ الخيار الأول هو إظهار تحذير عند تعديل النطاق أو الورقة المحميَّة إذ تظهر رسالة تنبهك إلى أنَّه لا يفترض تعديل هذا النطاق وإن كنت واثقًا من التعديل فاضغط موافق سواءً لك أو لمن تشاركهم الملف. الخيار الثاني هو تقييد من يمكنه تعديل النطاق أو الورقة ومنع جميع الأشخاص من التعديل باختيار “أنت فقط” أو اختيار “مخصص” للسماح لبعض الأشخاص من التعديل على الورقة أو النطاق بوضع إشارة بجانب أسمائهم. عند حماية الورقة أو الخلايا لن يتمكن الآخرون من التعديل عليها ولكن يستطيعون رؤيتها بحسب الإذن المعطى لهم. يمكن حماية حقول الوصف ونسبة ومقدار الضريبة والإجمالي في جدول بيانات المبيعات حتى لا يعبث أحدٌ بها فنحصل على معلومات خاطئة بالطريقة نفسها ولكن نختار “حماية نطاق” بدلًا من ورقة. فكرة إضافية: يمكن في جدول المخزون وضع سعر لكل قطعة وعندما نختار رقم المنتج يوضع سعرها في حقل بيانات المبيعات مباشرةً مثل حقل الوصف وهنا نحتاج إلى حقل يصف عدد المنتجات المُباعة وبذلك نحمي سعر المنتج ويتبقى إدخال التاريخ والوقت ورقم المنتج وعدد القطع المُباعة فقط. التنسيق الشرطي يُستعمل التنسيق الشرطي لتنسيق الخلايا اعتمادًا على مجموعة من القواعد يحدِّدها المستخدم والتي توازن محتوى الخليَّة مع تلك القواعد وتنسِّقها بناءً على ذلك. نستعمله في جعل لون الخليَّة أحمر مثلًا إن كانت تحوي عبارة “راسب” ليسهل علينا تحديد الطلاب الراسبين أو إن كانت قيمة الخليَّة أقل أو أكبر من قيمة معيَّنة؛ توجد الكثير من القواعد لتنسيق النصوص والتواريخ والأرقام ويمكن تخصيص قاعدة جديدة غير موجودة. يوفر تطبيق جداول بيانات google نوعين من التنسيق هما: لون فردي وتدرج ألوان؛ سنُنسق حقل مقدار الضريبة باللون الفردي لتحديد قيمة الضريبة الأقل من 200 ليرة. نحدِّد حقل مقدار الضريبة ونضغط بزر الفأرة الأيمن ونختار “تنسيق شرطي” أو من قائمة التنسيق ← تنسيق شرطي ثمَّ نختار قاعدة “أصغر من أو يساوي” ثمَّ نضع القيمة 200 ونحدِّد تنسيق الخليَّة ونضغط “تم“. سنُنسق حقل الإجمالي وفق تنسيق التدرج اللوني لمعرفة القيمة العظمى والقيمة الصغرى المباعة في اليوم. نضغط على إضافة قاعدة جديدة ونختار “تدرج اللون” ثمَّ نحدِّد خلايا الحقل في مربع “ينطبق على نطاق”؛ نختار التدرج اللوني المناسب ثمَّ نختار “الحد الأدنى” من خيارات القيمة الدنيا وخيار “الحد الأقصى” من خيارات القيمة العظمى. يظهر تنسيق الحقل كما موضح في الصورة. توجد قواعد كثيرة في التنسيق الشرطي تنتظرك لاستكشافها والتي تسهِّل عليك تنسيق جدولك وتحليل البيانات وقراءتها بسرعة. الخاتمة انتهينا من إنشاء تقرير المبيعات وأصبح جاهزًا لملء البيانات فيه وآمنًا لمشاركته مع الآخرين. إنَّ ما تعلمته إلى الآن يمكِّنك من إنشاء أغلب الجداول التي ستلزمك في جميع أمور حياتك اليوميَّة وبأفضل تصميم؛ كل ما عليك هو فتح تطبيق جداول بيانات جوجل والبدء بتصميم جدولك.
  2. سنتحدث في هذا الدرس عن كيفيَّة تحضير المستند لطباعته ونشره على الويب أو إرساله عبر البريد, وسنتطرق أيضًا إلى إضافة جدول المحتويات ومراجعة المستند وتدقيقه والاستفادة من الإشارات المرجعيَّة. إدراج جدول محتويات يتضمَّن جدول المحتويات قائمةً بعناوين الفقرات بكافة مستوياتها مع أرقام الصفحات المتواجدة فيها، ويمكن الضغط على كل عنوان فيه للانتقال إلى الصفحة الموجود فيها مباشرةً وبسرعة. سندرج جدول محتويات لإحدى المقالات عبر إدراج ← جدول المحتويات وسنجد خيارين هما: بأرقام الصفحات وبروابط زرقاء. إدراج جدول محتويات بأرقام الصفحات شبيهٌ بجدول محتويات الكتب إذ يوضع بجانب كل عنوان رقم الصفحة الموجود فيها بالإضافة إلى قابليَّة الضغط على العنوان ورقم الصفحة للانتقال إليها مباشرةً. أمَّا جدول المحتويات بروابط زرقاء فهو يشبه جدول المحتويات في ويكيبيديا إذ لا توجد صفحات عند النشر في الويب ولكن تبقى قابليَّة الضغط على العنوان متاحة للانتقال إليه مباشرةً. عند وضع المؤشر على أحد العناوين في جدول المحتويات تظهر ثلاثة خيارات؛ الخيار الأول هو رابط ينقلنا عند الضغط عليه إلى صفحة العنوان، والخيار الثاني "تغيير" لتغيير الرابط في حال التعديل على العنوان الحالي وتبديله، والخيار الثالث هو "إزالة" لإزالة الرابط ويصبح بذلك غير قابل للضغط وكأنَّه مجرد نص عادي. يجب تحديث جدول المحتويات عند التعديل على العناوين أو إضافة أخرى جديدة بالضغط على تحديث . سنغير تنسيق جدول المحتويات باستعمال إضافة "Table of contetnts" التي أضفناها في درس سابق لترقيم العناوين بحسب مستوياتها حيث نختار تنسيق الترقيم "1.2.3" كما موضح بالصورة. الإشارات المرجعيَّة يتيح تطبيق مستندات جوجل ترك علامة مرجعيَّة في أي موقع من المستند للرجوع إليها لاحقًا واستئناف العمل من المكان الذي تركناه آخر مرَّة. إن كان عدد صفحات المستند كبيرًا وكنت تدقِّقه على سبيل المثال فيمكنك ترك إشارة مرجعيَّة في المكان الذي توقفت فيه للعودة إليه في المرة القادمة بسرعة. ندرج إشارة مرجعيَّة عبر إدراج ← إشارة. عند فتح المستند مرة أخرى استخدم الاختصار Ctrl + Alt + N للانتقال إلى الإشارة المرجعيَّة التالية والاختصار Ctrl + Alt + B للرجوع إلى الإشارة المرجعيَّة السابقة. لمعرفة المزيد من الاختصارات افتح نافذة الاختصارات عبر مساعدة ← اختصارات لوحة المفاتيح. يمكن إنشاء جدول في بداية المستند يحوي عباراتٍ نربطها مع إشارات مرجعيَّة لتسهيل التنقل بين صفحات المستند. نضيف جدولًا ونكتب المواقع التي نريد ربطها مع الإشارات المرجعيَّة التي أضفناها سابقًا ثمَّ نختار من شريط القوائم إدراج رابط ولكن عوضًا عن إدراج رابط نُدرج الإشارة المرجعيَّة التي نريد ربطها مع العبارة كما موضح بالصورة. ملاحظة: يمكن إنشاء جدول محتويات يدويًا وذلك بكتابة العناوين التي نريدها ثمَّ نربطها باختيار "العناوين" بدلًا من "إشارات مرجعيَّة" ونحدِّد العنوان المناسب. طباعة المستند وتنزيله إن أردنا طبع مستند نختار ملف ← طباعة أو نضغط على الاختصار Ctrl + P للانتقال إلى إعدادات الطباعة. نُزِيلُ الهوامش الإضافيَّة التي تحتوي على معلومات عن المستند مثل رابط المستند واسمه وتاريخ التعديل من القائمة اليسرى أو يدويًا ثمَّ نختار عدد الصفحات التي نريد طباعتها ونحدِّد الطابعة. توجد خيارات طبع إضافيَّة مثل نوع الورق والطباعة على وجه واحد أو وجهين وطباعة الصفحات الزوجيَّة أو الفرديَّة ...إلخ. تجدها بالضغط على الخيار "Print using system dialog" أو استعمال الاختصار Ctrl + Shift + P. الطابعة الافتراضيَّة هي "التصدير إلى ملف بصيغة PDF" لتنزيله إلى الحاسوب ثمَّ طباعته؛ إن كنت تملك طابعة موصولة إلى حاسوبك ومعرَّفة فتستطيع إضافتها إلى خدمة الطباعة من السحابة من جوجل للطباعة مباشرةً من تطبيق مستندات جوجل. خطوات إعداد الطابعة لاستخدام خدمة الطباعة من السحابة هي: وصِّل الطابعة بالحاسوب ثمَّ شغلها وعرفها. افتح متصفح chrome. تحقق من توافق طابعتك مع خدمة الطباعة من السحابة من جوجل عبر الخطوات التالية: انتقل إلى صفحة الطابعات المجهزة للطباعة من السحابة وابحث عن طابعتك. إذا وجدت عبارة "v2" بجوار اسم طابعتك فذلك يعني أنَّها مجهَّزة للطباعة من السحابة (الإصدار 2.0). أمَّا إذا لم تجد تلك العبارة فذلك يعني أنَّ طابعتك مجهَّزة للطباعة من السحابة (الإصدار 1.0). إن لم تكن طابعتك مُدرَجةً بالقائمة فذلك يعني عدم توافق طابعتك مع خدمة الطباعة من السحابة. وصِّل طابعتك بخدمة الطباعة من السحابة باتباع الخطوات التالية: اكتب chrome://devices ثمَّ اضغط على Enter. إذا كانت طابعتك غير متوافقة مع خدمة الطباعة من السحابة فاضغط على "إضافة طابعات" ضمن الطابعات التقليديَّة ثمَّ حدِّد الطابعة التي تريد مشاركتها واضغط على "إضافة الطابعات". إن كانت طابعتك مجهَّزةٌ للطباعة من السحابة ذات الإصدار 2.0 فابحث عنها ضمن الأجهزة الجديدة ثمَّ اضغط على "إدارة" بجوارها ثمَّ "تسجيل" واضغط على "تأكيد التسجيل" الذي يَظهر لك واتبع الخطوات اللاحقة لإضافتها. أمَّا إن كانت طابعتك ذات إصدار 1.0 فانتقل إلى موقع الشركة المصنِّعة لطابعتك من صفحة الطابعات المجهَّزة للطباعة والموجود في الجزء السفلي من اسم الشركة واتَّبع الخطوات. تأكَّد من توصيل طابعتك بشكل صحيح بالانتقال إلى google.com/cloudprint ثمَّ الضغط على "الطابعات". للمزيد من التفاصيل انتقل إلى صفحة المساعدة من جوجل. بعد تهيئة الطابعة للطباعة من السحابة، عد إلى خيارات الطباعة واضغط على "change" ثمَّ حدِّد طابعتك التي أضفتها للتو واطبع مباشرةً من مستندات جوجل. يمكن تنزيل المستند بصيغ عدَّة إلى حاسوبك وذلك يشبه خيار التصدير في التطبيقات المشابهة، ويمكنك بعد تنزيله على حاسوبك طباعته إن أردت. النشر يوفِّر تطبيق مستندات جوجل خيارات سريعة لنشر المستند أو إرفاقه عبر البريد الإلكتروني وإرساله إلى أحد الأشخاص وهي: النشر على الويب: هو إتاحة المستند على الويب ليتمكن أي شخص من البحث عنه ومشاهدته، ويمكنك نشر رابطه عبر مواقع التواصل الاجتماعي. عند تعيين الخيار "إعادة النشر تلقائيًّا عند إجراء التغييرات" يُحدَّث المستند المنشور على الويب خلال فترات زمنيَّة منتظمة لضمان نشره مع آخر التغييرات التي أُجريت عليه. إرسال رسالة إلكترونيَّة إلى المتعاونين: هو إرسال رسالة إلى الأشخاص المتعاونين الذين ساهموا في التعديل أو التعليق على المستند أي كل من شاركناهم المستند، وكتابة رسالة لهم مع إرفاق رابط المستند. الرسالة التي يستلمونها شبيهة بالرسالة التي تصلهم عند دعوتهم للمشاركة. إرسال بالبريد الإلكتروني كمرفق: هو إرفاق المستند وفق الصيغة التي تختارها مع رسالة إلى أحد الأشخاص عبر البريد الإلكتروني. الخاتمة تعرَّفنا في هذه المقالة على التشطيبات النهائيَّة التي نجريها على المستند وهي إدراج جدول المحتويات وطباعة المستند ونشره على الويب أو إرفاقه عبر البريد. إنَّ هذا التطبيق قيد التطوير وقد يضاف إليه بعض المزايا والأدوات في المستقبل.
  3. تعرَّفنا في درسنا السابق على خيارات الإدراج التي يوفرها تطبيق مستندات جوجل ومنها المعادلات والكائنات الرسوميَّة؛ سننتقل في درسنا هذا إلى محطة أخرى نتعرَّف فيها على بعض الخصائص التي يوفِّرها التطبيق. نبدأ أولًا بخياري إنشاء نسخة وتاريخ النُسخ ثمَّ سنتعرف بعدها على الإضافات وكيفيَّة تثبيت بعضًا منها وتشغيلها والاستفادة منها وكيفية إلغاء تثبيتها. إنشاء نسخة يُستعمل هذا الخيار لإنشاء نسخة من المستند المفتوح بغرض مشاركتها أو التعديل عليها بشكل منفصل عن النسخة الأصليَّة؛ عند إنشاء نسخة تُمسح جميع التعليقات الموجودة على المستند الأصلي. يمكن إنشاء نسخة عبر القائمة ملف ← إنشاء نسخة وتحديد مكان حفظها. لا تدعم النسخة العربيَّة من مستندات جوجل إدراج القوالب الجاهزة للأسف؛ عند فتح النسخة الإنجليزية يُعرض عليك خيارات عديدة من القوالب والنماذج الجاهزة كما يمكنك البحث ضمن جوجل عن أي نموذج أو قالب وإضافته مباشرةً إلى مستنداتك وهذا غير متوافر في النسخة العربيَّة. الحل هو البحث عن قوالب ونماذج جاهزة ثمَّ تنزيلها إلى حاسوبك وتحميلها وفتحها عبر تطبيق مستندات جوجل، بما أنَّه يدعم صيغ عدَّة، والتعديل عليها. يوفر موقع ورقي مكتبة هائلة من القوالب والتقارير والنماذج الجاهزة والمجانيَّة التي تعمل على تطبيقات مايكروسوفت أوفيس؛ يمكنك أيضًا استعمال قوالب جاهزة من مايكروسوفت حيث يمكنك اختيار القالب المناسب وتحمليه إلى تطبيق مستندات جوجل والتعديل عليه وهي مجانيَّة أيضًا . تاريخ النُسخ يوفر تطبيق مستندات جوجل ميِّزة حفظ نُسخ متعدِّدة من المستند تلقائيًّا أثناء كتابته أو تعديله وذلك للرجوع إليها واستعادتها عند الحاجة إلى ذلك، ولعرضها نختار من قائمة ملف ← تاريخ النسخة ← الإطلاع على سجل النُسخ. عند الضغط على خيار "الإطلاع على سجل النسخ" ينقلك التطبيق إلى صفحة معاينة لعرض النُسخ المحفوظة حيث يمكنك من القائمة الواقعة على اليسار اختيار نُسخة من تاريخ معين أو معاينتها والإطلاع على الاختلافات بينها وبين النسخة الحالية كما يمكنك معرفة الشخص الذي عدَّل على كل نسخة. يمكنك تسمية النسخ بأسماء محدَّدة مما يسهل عليك التمييز بينها عند الرجوع إليها وذلك إما بالضغط على الاسم (٨ أكتوبر، ٢:٠١ م) مثلًا وتغييره أو إضافة اسم جديد لكل إصدار عند فتح المستند عبر الخيار ملف ← تاريخ النسخة ← اختيار اسم للإصدار الحالي. عند الرغبة بالرجوع إلى إصدار سابق حدِّده واضغط على "استعادة هذه النسخة" لتصبح النسخة الحالية، ولا تقلق على النسخة التي كنت تعمل عليها لأنَّها ستُدرج ضمن قائمة النسخ السابقة ويمكنك استعادتها فيما بعد. الإضافات الوظيفة الأساسيَّة للإضافات هي توسيع عمل تطبيق مستندات جوجل وسائر التطبيقات (جداول البيانات والعرض التقديمي والنماذج) وإضافة مزايا جديدة لا يدعمها التطبيق. سنتعرف على الإضافات بشكل عملي إذ سنضيف بعض الإضافات ونشغلها ضمن المستند ونتعرف على المزايا التي وسَّعت من عمل التطبيق، ثمَّ سنزيل الإضافات التي لا حاجة لنا بها. تثبيت الإضافات وتشغيلها سنثبِّت إضافة جديدة عبر إضافات ← الحصول على إضافات فتظهر النافذة التالية: يمكننا البحث عن إضافة محدَّدة بكتابة اسمها في مربع البحث، أو يمكننا تصفية المحتوى بالضغط على "الكل" واختيار فئة معيَّنة. عند وضع مؤشر الفأرة فوق الإضافة يظهر شرح مبسَّط لوظيفتها وفي أسفل ذلك الشرح يوجد زر "مجانًا" لتثبيتها، وللمزيد من المعلومات حول الإضافة اضغط عليها؛ جميع الإضافات وشرحها باللغة الإنجليزية. ألم تلاحظ وجود عدد قليل من الخطوط؟ دعنا نبحث عن إضافة تتيح استعمال المزيد من الخطوط. سنكتب في مربع البحث "fonts" للبحث عن إضافة توفر المزيد من الخطوط. نجد إضافة اسمها "Extensis Fonts"؛ نضغط عليها لمعرفة الخدمات التي تزودنا بها فنجد أنَّها تتيح لنا الوصول إلى ما يزيد عن 1200 خط وهذا كاف. قررنا تثبيتها لذا نضغط على "مجانًا" أعلى يسار النافذة. ننتقل إلى نافذة جديدة يُطلب فيها تحديد اسم الحساب فنحدِّده ثمَّ تظهر رسالة تَطلب منك السماح للإضافة بالوصول إلى بياناتك والتعديل عليها وغيرها من الصلاحيات والأمر عائدٌ لك بالسماح أو الرفض. ثُبِّتت الإضافة بنجاح ولاستعمالها نشغلها عبر الخيار إضافات ← Extensis Fonts ← ‏start. تظهر قائمة في الطرف الأيسر موضحة بالصورة التالية: نحدِّد النص ونختار الخط المناسب من القائمة؛ جميع الخطوط مرتَّبة وفق الترتيب الهجائي لذا يمكن تحديد أي خط تعرف اسمه. نلاحظ تغير قائمة الخطوط ضمن البرنامج لتتوسع أكثر ويصبح بإمكاننا إضافة أي خط من الخيار "مزيد من الخطوط". يمكننا الآن إضافة أي خط وذلك بالبحث عنه بواسطة خطوط جوجل ثمَّ نأخذ اسم الخط المطلوب ونضغط على خيار "مزيد من الخطوط" ثمَّ نكتب اسم الخط ضمن مربع البحث في الأعلى ونضيفه إلى القائمة. إدارة الإضافات يمكن معرفة الإضافات المرتبطة مع المستند عبر الخيار إضافات ← إضافات المستند؛ يمكن فصل تلك الإضافات عبر الخيار إضافات ← إدارة الإضافات ثمَّ نحدِّد الإضافة ونضغط على "إدارة" ونُزِيلُ الإشارة الموجودة بجانب "استخدام في هذا المستند". يمكن إزالة الإضافة من القائمة السابقة نفسها عبر الخيار "إزالة". يوجد عدد هائل من الإضافات التي تلبي أغلب متطلبات المستخدمين لذا إن لزمك أي خدمة غير مدعومة في تطبيق مستندات جوجل فيمكنك البحث عن إضافة تلبي حاجتك. بعض الإضافات المفيدة: Translate: هي إضافة لترجمة الكلمات والجمل المحدَّدة لعدَّة لغات، وهي أداة مصغَّرة شبيهة بتطبيقات وأدوات الترجمة التي توفرها جوجل. Table formatter: إن كنت من مستخدمي تطبيق مايكروسوفت وورد فهذه الإضافة تتيح استعمال تنسيقات الجداول الجاهزة المشابهة لتلك الموجودة في تطبيق وورد. LucidChart Diagrams: تُستعمل لإدراج وإنشاء المخططات والخرائط الذاكريَّة بسرعة وسهولة. كل ما عليك فعله هو اختيار الشكل أو التصميم من بين المئات منها وسحبه إلى المستند. Table of content: تُستخدم لترقيم جميع العناوين والتعديل على جدول المحتوى. الخاتمة تعرَّفنا في هذا الدرس على بعض مزايا تطبيق مستندات جوجل وكان أهمها الإضافات التي توسِّع من الوظائف والخدمات التي يوفرها هذا التطبيق، وتجعله مرنًا ليخدم مختلف أنواع المستخدمين.
  4. سنتعلّم في هذه السلسلة من الدروس كيفية التعامل واستخدام حزمة برامج المكتب الرائعة من جوجل والتي نستطيع استخدامه عبر الحواسيب أونلاين (عبر الاتصال بالإنترنت) بدون تنصيب أو عبر تنصيبها على الهاتف المحمول وهي مجانية. في هذه السلسلة سنبدأ بتعلم استخدام تطبيق مستندات جوجل Google Docs وهو تطبيق محرر نصوص متطور يغنيك عن استخدام برنامج Microsoft Word ذو السعر المرتفع كما يغنيك عن تنصيب واستخدام برنامج Writer المفتوح المصدر من Liber أو غيرها. ويتميز هذا التطبيق بأن جميع الملفات التي يتم إنشاؤها يتم حفظها على سحابة جوجل درايف Goolge Drive الخاصة بك تلقائيًا كما يتم حفظ التعديلات التي يتم إجراؤها تلقائيًا أيضًا، لذلك لن تضطر للقلق بشأن انقطاع الكهرباء أو فروغ بطارية الجهاز المحمول (أيًا كان) أو توقف البرنامج أو النظام عن العمل لأي سبب، فالتعديلات التي تم إجراؤها يتم حفظها لحظة بلحظة ببساطة ويمكنك العودة إلى التطبيق ومتابعة العمل من حيث توقفت. لنبدأ أولًا بالتعرّف على كيفية البدء باستخدام هذا التطبيق على مختلف المنصات. البدء باستخدام التطبيق وإنشاء مستند جديد الحاسوب يمكنك البدء عبر الحاسوب ومن أي نظام تشغيل العمل عبر أي متصفح إنترنت للدخول إلى التطبيق بطريقتين: أولًا: عبر الموقع https://docs.google.com/ لتظهر لك نافذة التطبيق التي تضم مجموعة الملفات الأخيرة التي تم العمل عليها باستخدام هذا التطبيق ولإنشاء مستند جديد عليك بالنقر على إشارة + ضمن الدائرة الحمراء أسفل يسار الشاشة. ثانيًا: عبر موقع سحابة جوجل درايف Google Drive عبر الموقع https://drive.google.com/ ثم نختار من الزر (جديد) الموجود أعلى الصفحة خيار (مستندات Google) ليفتح لنا التطبيق مستند جديد فارغ جاهز للكتابة. الهاتف المحمول قم بتحميل تطبيق Google Docs من سوق Play Google لأنظمة الأندرويد أو من سوق iTunes لأنظمة iOS. وعند فتح التطبيق ستظهر لك الملفات الأخيرة التي عملت عليها بالإضافة إلى قائمة أدوات البرنامج الرئيسية في الأعلى و زر إنشاء ملف جديد على شكل دائرة حمراء أسفل يمين الشاشة. ولدى النقر عليه سيظهر خيارين لإنشاء ملفات جديدة فإما أن يتم إنشاء مستند جديد من قالب فارغ أو من قالب جاهز. ومن ثم ستظهر لك شاشة المستند الفارغ الجديد والتي تضم أدوات تحرير النصوص المعتادة أعلى وأسفل الشاشة بالإضافة إلى المزيد من الخيارات من خلال قائمة البرنامج التي ستظهر بمجرد النقر على النقاط الثلاث العمودية أعلى يمين الشاشة. وهذه هي قائمة البرنامج وتضم ما تحتاج إليه لإنشاء وتحرير النصوص. حفظ الملف في هذا التطبيق لن تجد خيار الحفظ أو الحفظ باسم في أي من قوائمه لأن ميزة هذا التطبيق أنه يحفظ تلقائيًا المستندات التي تعمل عليه لحظة بلحظة على سحابة Google Drive الخاصة بك ولذلك لن تضيع أية تفاصيل قمت بإدخالها لأي سبب كان. ولتمييز الملفات عن بعضها سنحتاج إلى كتابة عنوان لكل مستند وذلك سهل عبر النقر على العنوان (بلا اسم) أعلى صفحة التطبيق ليصبح قابلًا للتحرير ثم تدخل العنوان الخاص بك. وقمت بتغييره إلى "مستند تجربة" كما يلي مزايا إضافية يتميز هذا التطبيق بأنه من الممكن مشاركة المستند مع أشخاص آخرين يملكون حسابًا على Google بحيث يمكن القيام بعمل جماعي على المستندات و يتم تقسيم العمل فيقوم الشخص الأول بكتابة الجزء المتعلق بفقرة معينة ليقوم شخص آخر بكتابة فقرة أخرى وهكذا، وكذلك قد يقوم شخص آخر بتدقيق الملف لغويًا وإملائيًا وقد تقع على عاتق شخص آخر مهمة تأمين الصور وإدراجها و...الخ. يمكن أن يقوم الأشخاص المخولين بإضافة التعليقات على المستند والتفاعل حول مواضيعه. يستطيع هذا التطبيق فتح جميع أنواع المستندات النصية العادية أو المكتبية كملفات Microsoft Word من نوع doc أو docx وملفات LiberWriter من نوع odt وغيرها بسهولة والتعديل عليها بدون أية مشاكل تتعلق بالتنسيق أو غيرها. يمكن تحميل العديد من الإضافات على التطبيق لتسهيل العمل أو لإضافة مزايا جديدة من خلال قائمة Add-ons . يمكن البحث عن أية كلمة أو جملة بمجرد تحديدها والضغط على زر الفأرة الأيمن واختيار البحث عنها في محرك بحث جوجل. يمكن العمل Offline أي بدون الاتصال بالانترنت وسيقوم بمزامنة البيانات كاملة بمجرد الاتصال بالإنترنت وهذه الميزة متوفرة لمتصفحات جوجل كروم. يمكن نسخ أية كلمة أو جملة أو فقرة أو حتى صورة إلى الويب بشكل متعدد أي نسخ العديد من العناصر وإعادة استخدامها في أي وقت لاحق. يقوم هذا التطبيق في حال بدأت الكتابة في سطر جديد باللغة الإنجليزية أو الفرنسية بجعل محاذاة الكتابة تلقائيًا من اليسار لليمين وبالعكس في حال الكتابة باللغة العربية أي أنك لست مضطرًا لضغط زرين يمين أو يسار لوحة المفاتيح لتحديد محاذاة النص. والكثير من المزايا الأخرى التي تجعل هذا التطبيق أكثر تميّزًا عن البرامج المشابهة وبمجرد أن تبدأ باستخدامه والتعرّف عليه بالإضافة إلى التطبيقات المرافقة الأخرى المكتبية كتطبيق Sheets المشابه لبرامج Excel من مايكروسوفت أو Calc من ليبر أوفيس وتطبيق Slides المشابهة لبرامج PowerPoint من مايكروسوفت وبرنامج Impress من ليبر أوفيس فإنك بكل بساطة قد تلجأ إلى إزالة هذه الحزم من حاسوبك وتستغني عنها.