• 0

مشكلة اصدارات حزم flutter

السلام عليكم ورحمة الله وبركاته

احاول الانتقال الى فلاتر 2 ولكن واجهتني بعض المشاكل في توافق الحزم الخاص بها حاولت تغير الاصدارات كثير ولكن المشكله تواجهني مع استعمال easy_localization ^3.0.0 وانا محتاج الى استعمال هذا الاصدار لترجمة التطبيق

هل من حل لهذا المشكله لجعل الحزم متوافقه مع بعض ؟

Because no versions of flutter_launcher_icons match >0.8.1 <0.9.0 and flutter_launcher_icons 0.8.1 depends on args ^1.5.0, flutter_launcher_icons ^0.8.1 requires args ^1.5.0.
And because easy_localization >=3.0.0-nullsafety depends on args ^2.0.0, flutter_launcher_icons ^0.8.1 is incompatible with easy_localization >=3.0.0-nullsafety.
So, because flutter_appifjoie depends on both easy_localization ^3.0.0 and flutter_launcher_icons ^0.8.1, version solving failed.
pub get failed (1; So, because flutter_appifjoie depends on both easy_localization ^3.0.0 and flutter_launcher_icons ^0.8.1, version solving failed.)
Process finished with exit code 1
  flutter_local_notifications: ^4.0.1+2
  firebase_auth_web: ^0.3.3
  firebase_messaging: ^6.0.16
  firebase_auth: ^0.20.1
  easy_localization: ^3.0.0
  firebase_core: ^0.7.0
  firebase_dynamic_links: ^0.7.0+1
  flutter_launcher_name: ^0.0.1
  flutter_launcher_icons: ^0.8.1
  firebase_analytics: ^7.0.1
  intl: 0.17.0
  firebase_admob: ^0.9.0+10
  shared_preferences: ^2.0.0
  url_launcher: ^6.0.3
  share: ^2.0.1
  google_sign_in: ^4.5.9
  http: ^0.12.2
  device_info: ^2.0.0
  splashscreen: ^1.3.5
  bottom_navy_bar: ^6.0.0

 

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 1
بتاريخ 1 دقيقة مضت قال مروان مروان3:

dependencies:
  flutter_local_notifications: ^4.0.1+2
  firebase_auth_web: ^0.3.3
  firebase_messaging: ^6.0.16
  firebase_auth: ^0.20.1
  easy_localization: ^2.1.0+0
  firebase_core: ^0.7.0
  firebase_dynamic_links: ^0.7.0+1
  flutter_launcher_name: ^0.0.1
  flutter_launcher_icons: ^0.9.0
  firebase_analytics: ^7.0.1
  intl: 0.16.1
  firebase_admob: ^0.9.0+10
  shared_preferences: ^0.5.12+4
  url_launcher: ^6.0.3
  share: ^2.0.1
  google_sign_in: ^4.5.9
  http: ^0.12.2
  device_info: ^2.0.0
  splashscreen: ^1.3.5
  bottom_navy_bar: ^6.0.0

  flutter:
    sdk: flutter


Because flutter_launcher_icons >=0.9.0 depends on yaml ^3.0.0-nullsafety.0 and flutter_launcher_name 0.0.1 depends on yaml ^2.1.16, flutter_launcher_icons >=0.9.0 is incompatible with flutter_launcher_name 0.0.1.
And because no versions of flutter_launcher_name match >0.0.1 <0.1.0, flutter_launcher_icons >=0.9.0 is incompatible with flutter_launcher_name ^0.0.1.
So, because flutter_appifjoie depends on both flutter_launcher_name ^0.0.1 and flutter_launcher_icons ^0.9.0, version solving failed.
pub get failed (1; So, because flutter_appifjoie depends on both flutter_launcher_name ^0.0.1 and flutter_launcher_icons ^0.9.0, version solving failed.)

شاهد اخي الان هذا الكود لدي @بلال زيادة

هل يمكنك تجربة وضع 

flutter_launcher_name:
    git:
      url: https://github.com/ride4sun/flutter_launcher_name
      ref: "0.9.1"

أو 

flutter_launcher_icons: any

 

1 شخص أعجب بهذا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 1
بتاريخ 1 دقيقة مضت قال مروان مروان3:

هلا بيك اخي سبق وقمت بذلك ولكن واجهتني مشكله مختلفه 


Because flutter_launcher_icons >=0.9.0 depends on yaml ^3.0.0-nullsafety.0 and flutter_launcher_name 0.0.1 depends on yaml ^2.1.16, flutter_launcher_icons >=0.9.0 is incompatible with flutter_launcher_name 0.0.1.
And because no versions of flutter_launcher_name match >0.0.1 <0.1.0, flutter_launcher_icons >=0.9.0 is incompatible with flutter_launcher_name ^0.0.1.
So, because flutter_appifjoie depends on both flutter_launcher_name ^0.0.1 and flutter_launcher_icons ^0.9.0, version solving failed.
pub get failed (1; So, because flutter_appifjoie depends on both flutter_launcher_name ^0.0.1 and flutter_launcher_icons ^0.9.0, version solving failed.)
Process finished with exit code 1

ولو قمت بمتابع وتغير الخاص ب الاسم رح تنتقل المشكلة الى مكتبة فايرزبيز هنا تحدث مشكله اكبر حيث اني الفايربيز يصل الى نقطة في اخر اصدار المكاتب غير متوافقه تكون

يجب أن يكون إصدارالمكتبة بهذا الشكل 

flutter_launcher_icons: ^0.9.0

 

1 شخص أعجب بهذا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 1
بتاريخ الآن قال مروان مروان3:

@بلال زيادة

شاهد الان اخي اصدارات مكتبات 

flutter_launcher_icons

flutter_launcher_name

اخر اصدار ولكن غير متوافقات

لا ليس أخر إصدار شاهد الإجابة السابقة

1 شخص أعجب بهذا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 1
بتاريخ 4 دقائق مضت قال مروان مروان3:

هل يوجد حل لهذا المشكلة اخي؟


Because no versions of flutter_launcher_name match >0.0.1 <0.1.0 and flutter_launcher_name 0.0.1 depends on yaml ^2.1.16, flutter_launcher_name ^0.0.1 requires yaml ^2.1.16.
And because flutter_launcher_icons >=0.9.0 depends on yaml ^3.0.0-nullsafety.0, flutter_launcher_name ^0.0.1 is incompatible with flutter_launcher_icons >=0.9.0.
And because flutter_launcher_icons <0.4.0 requires SDK version >=1.20.1 <2.0.0 and flutter_launcher_icons >=0.4.0 <0.7.1 depends on image ^2.0.0, if flutter_launcher_name ^0.0.1 and flutter_launcher_icons <0.7.1-∞ or >=0.9.0 then image ^2.0.0.
And because image >=1.1.31 <2.0.4 depends on archive >=1.0.16 <1.1.0 and image >=2.1.14 <3.0.0-nullsafety.0 depends on archive ^2.0.0, if flutter_launcher_name ^0.0.1 and flutter_launcher_icons <0.7.1-∞ or >=0.9.0 then archive >=1.0.16 <1.1.0 or ^2.0.0 or image >=2.0.4 <2.1.14.
And because image >=2.0.4 <2.1.14 depends on archive >=1.0.16 <3.0.0 and archive ^1.0.2 requires SDK version <2.0.0, if flutter_launcher_name ^0.0.1 and flutter_launcher_icons <0.7.1-∞ or >=0.9.0 then archive ^2.0.0.
And because flutter_launcher_icons >=0.7.0 <0.9.0 depends on args ^1.5.0 and archive >=2.0.0 <3.0.0-nullsafety.0 depends on args ^1.4.0, if flutter_launcher_name ^0.0.1 and flutter_launcher_icons any then args ^1.4.0.
And because flutter_appifjoie depends on easy_localization ^3.0.0 which depends on args ^2.0.0, flutter_launcher_name ^0.0.1 is incompatible with flutter_launcher_icons.
So, because flutter_appifjoie depends on both flutter_launcher_name ^0.0.1 and flutter_launcher_icons any, version solving failed.
pub get failed (1; So, because flutter_appifjoie depends on both flutter_launcher_name ^0.0.1 and flutter_launcher_icons any, version solving failed.)

 

يمكنك تجربة وضع any مرة أخرى لأي حزمة، أو تأكد من أن لديك sdk flutter 2

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 1
بتاريخ الآن قال مروان مروان3:

هو من فتره انا ارغب بالانتقال الى فلاتر 2 ولكن متردد علشان توافق الحزم ولكن لما رغبت ارفع المشروع لك الثاني الذي في السوال المختلف وجدت الفرصه للقيام بذلك لكني سوف اكون مجبور بعد فتره على الانتقال الامر الان نجح على ما يبدو ان المشكله في حزمة ايقونة التطبيق فقط قمت بايقافها الى اشعار لاحق لا توجد مشكله واصبح المكاتب متوافقه جميعها 

 

مع العلم انني قمت بتجربة وضع any 

يجب الأنتقال إلى flutter 2 .

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0

هل يمكنك الذهاب إلى موقع pub.dev والبحث عن مكتبة flutter_launcher_icons ومن ثم تقوم بتحديثها عن طريق وضع أخر إصدار ومن ثم إخباري بالنتيجة, أو يمكنك تنفيذ الأمر التالي 

flutter pub upgrade

 

1 شخص أعجب بهذا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0
بتاريخ 1 دقيقة مضت قال بلال زيادة:

هل يمكنك الذهاب إلى موقع pub.dev والبحث عن مكتبة flutter_launcher_icons ومن ثم تقوم بتحديثها عن طريق وضع أخر إصدار ومن ثم إخباري بالنتيجة, أو يمكنك تنفيذ الأمر التالي 


flutter pub upgrade

 

هلا بيك اخي سبق وقمت بذلك ولكن واجهتني مشكله مختلفه 

Because flutter_launcher_icons >=0.9.0 depends on yaml ^3.0.0-nullsafety.0 and flutter_launcher_name 0.0.1 depends on yaml ^2.1.16, flutter_launcher_icons >=0.9.0 is incompatible with flutter_launcher_name 0.0.1.
And because no versions of flutter_launcher_name match >0.0.1 <0.1.0, flutter_launcher_icons >=0.9.0 is incompatible with flutter_launcher_name ^0.0.1.
So, because flutter_appifjoie depends on both flutter_launcher_name ^0.0.1 and flutter_launcher_icons ^0.9.0, version solving failed.
pub get failed (1; So, because flutter_appifjoie depends on both flutter_launcher_name ^0.0.1 and flutter_launcher_icons ^0.9.0, version solving failed.)
Process finished with exit code 1

ولو قمت بمتابع وتغير الخاص ب الاسم رح تنتقل المشكلة الى مكتبة فايرزبيز هنا تحدث مشكله اكبر حيث اني الفايربيز يصل الى نقطة في اخر اصدار المكاتب غير متوافقه تكون

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0

@بلال زيادة

شاهد الان اخي اصدارات مكتبات 

flutter_launcher_icons

flutter_launcher_name

اخر اصدار ولكن غير متوافقات

1 شخص أعجب بهذا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0
dependencies:
  flutter_local_notifications: ^4.0.1+2
  firebase_auth_web: ^0.3.3
  firebase_messaging: ^6.0.16
  firebase_auth: ^0.20.1
  easy_localization: ^2.1.0+0
  firebase_core: ^0.7.0
  firebase_dynamic_links: ^0.7.0+1
  flutter_launcher_name: ^0.0.1
  flutter_launcher_icons: ^0.9.0
  firebase_analytics: ^7.0.1
  intl: 0.16.1
  firebase_admob: ^0.9.0+10
  shared_preferences: ^0.5.12+4
  url_launcher: ^6.0.3
  share: ^2.0.1
  google_sign_in: ^4.5.9
  http: ^0.12.2
  device_info: ^2.0.0
  splashscreen: ^1.3.5
  bottom_navy_bar: ^6.0.0

  flutter:
    sdk: flutter

Because flutter_launcher_icons >=0.9.0 depends on yaml ^3.0.0-nullsafety.0 and flutter_launcher_name 0.0.1 depends on yaml ^2.1.16, flutter_launcher_icons >=0.9.0 is incompatible with flutter_launcher_name 0.0.1.
And because no versions of flutter_launcher_name match >0.0.1 <0.1.0, flutter_launcher_icons >=0.9.0 is incompatible with flutter_launcher_name ^0.0.1.
So, because flutter_appifjoie depends on both flutter_launcher_name ^0.0.1 and flutter_launcher_icons ^0.9.0, version solving failed.
pub get failed (1; So, because flutter_appifjoie depends on both flutter_launcher_name ^0.0.1 and flutter_launcher_icons ^0.9.0, version solving failed.)

شاهد اخي الان هذا الكود لدي @بلال زيادة

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0
بتاريخ 2 دقائق مضت قال بلال زيادة:

هل يمكنك تجربة وضع 


flutter_launcher_name:
    git:
      url: https://github.com/ride4sun/flutter_launcher_name
      ref: "0.9.1"

أو 


flutter_launcher_icons: any

 

اهلا اخي قمت بستعمال flutter_launcher_icons: any

وذهب الخطاء ولكن ما المقصود بكتابة المكتبه بهذا الشكل بتحديد؟ هل الكود يختار المناسب المتوافق الاصدار؟ اذا كان نعم هل يكون اصدار حديث يعني او عادي يكون من بداية الاصدارات او هو يبحث عن احدث اصدار ممكن يتوافق؟

 

ايضا الكود الاكود ماذا يفرق عن الثاني اخي ؟

@بلال زيادة

مشكلة الايقونة والاسم اختفت ولكن بعد محاولة عمل حزمة الترجمه الاخيره ظهرت مشاكل ممتاليه وهذا النتتيجة النهائية بعد محاولتي تعديلها

  flutter_local_notifications: ^5.0.0+4
  firebase_messaging: ^9.1.4
  firebase_auth: ^1.1.4
  easy_localization: ^3.0.0
  firebase_core: ^1.1.1
  firebase_dynamic_links: ^2.0.3
  flutter_launcher_name: ^0.0.1
  flutter_launcher_icons: any
  firebase_analytics: ^7.0.1
  intl: 0.17.0
#  firebase_admob: ^0.9.0+10
  shared_preferences: any
  url_launcher: ^6.0.3
  share: ^2.0.1
  google_sign_in: ^4.5.9
  http: ^0.13.3
  device_info: ^2.0.0
  splashscreen: ^1.3.5
  bottom_navy_bar: ^6.0.
Because no versions of flutter_launcher_name match >0.0.1 <0.1.0 and flutter_launcher_name 0.0.1 depends on yaml ^2.1.16, flutter_launcher_name ^0.0.1 requires yaml ^2.1.16.
And because flutter_launcher_icons >=0.9.0 depends on yaml ^3.0.0-nullsafety.0, flutter_launcher_name ^0.0.1 is incompatible with flutter_launcher_icons >=0.9.0.
And because flutter_launcher_icons <0.4.0 requires SDK version >=1.20.1 <2.0.0 and flutter_launcher_icons >=0.4.0 <0.7.1 depends on image ^2.0.0, if flutter_launcher_name ^0.0.1 and flutter_launcher_icons <0.7.1-∞ or >=0.9.0 then image ^2.0.0.
And because image >=1.1.31 <2.0.4 depends on archive >=1.0.16 <1.1.0 and image >=2.1.14 <3.0.0-nullsafety.0 depends on archive ^2.0.0, if flutter_launcher_name ^0.0.1 and flutter_launcher_icons <0.7.1-∞ or >=0.9.0 then archive >=1.0.16 <1.1.0 or ^2.0.0 or image >=2.0.4 <2.1.14.
And because image >=2.0.4 <2.1.14 depends on archive >=1.0.16 <3.0.0 and archive ^1.0.2 requires SDK version <2.0.0, if flutter_launcher_name ^0.0.1 and flutter_launcher_icons <0.7.1-∞ or >=0.9.0 then archive ^2.0.0.
And because flutter_launcher_icons >=0.7.0 <0.9.0 depends on args ^1.5.0 and archive >=2.0.0 <3.0.0-nullsafety.0 depends on args ^1.4.0, if flutter_launcher_name ^0.0.1 and flutter_launcher_icons any then args ^1.4.0.
And because flutter_appifjoie depends on easy_localization ^3.0.0 which depends on args ^2.0.0, flutter_launcher_name ^0.0.1 is incompatible with flutter_launcher_icons.
So, because flutter_appifjoie depends on both flutter_launcher_name ^0.0.1 and flutter_launcher_icons any, version solving failed.
pub get failed (1; So, because flutter_appifjoie depends on both flutter_launcher_name ^0.0.1 and flutter_launcher_icons any, version solving failed.)

 

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0
بتاريخ 5 دقائق مضت قال مروان مروان3:

اهلا اخي قمت بستعمال flutter_launcher_icons: any

وذهب الخطاء ولكن ما المقصود بكتابة المكتبه بهذا الشكل بتحديد؟ هل الكود يختار المناسب المتوافق الاصدار؟ اذا كان نعم هل يكون اصدار حديث يعني او عادي يكون من بداية الاصدارات او هو يبحث عن احدث اصدار ممكن يتوافق؟

 

ايضا الكود الاكود ماذا يفرق عن الثاني اخي ؟

يقوم بجلب أخر إصدار , الكود الأول هو يقوم بجلب المكتبة من المستودع الخاص بها من github.

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0
بتاريخ 7 دقائق مضت قال بلال زيادة:

يقوم بجلب أخر إصدار , الكود الأول هو يقوم بجلب المكتبة من المستودع الخاص بها من github.

هل يوجد حل لهذا المشكلة اخي؟

Because no versions of flutter_launcher_name match >0.0.1 <0.1.0 and flutter_launcher_name 0.0.1 depends on yaml ^2.1.16, flutter_launcher_name ^0.0.1 requires yaml ^2.1.16.
And because flutter_launcher_icons >=0.9.0 depends on yaml ^3.0.0-nullsafety.0, flutter_launcher_name ^0.0.1 is incompatible with flutter_launcher_icons >=0.9.0.
And because flutter_launcher_icons <0.4.0 requires SDK version >=1.20.1 <2.0.0 and flutter_launcher_icons >=0.4.0 <0.7.1 depends on image ^2.0.0, if flutter_launcher_name ^0.0.1 and flutter_launcher_icons <0.7.1-∞ or >=0.9.0 then image ^2.0.0.
And because image >=1.1.31 <2.0.4 depends on archive >=1.0.16 <1.1.0 and image >=2.1.14 <3.0.0-nullsafety.0 depends on archive ^2.0.0, if flutter_launcher_name ^0.0.1 and flutter_launcher_icons <0.7.1-∞ or >=0.9.0 then archive >=1.0.16 <1.1.0 or ^2.0.0 or image >=2.0.4 <2.1.14.
And because image >=2.0.4 <2.1.14 depends on archive >=1.0.16 <3.0.0 and archive ^1.0.2 requires SDK version <2.0.0, if flutter_launcher_name ^0.0.1 and flutter_launcher_icons <0.7.1-∞ or >=0.9.0 then archive ^2.0.0.
And because flutter_launcher_icons >=0.7.0 <0.9.0 depends on args ^1.5.0 and archive >=2.0.0 <3.0.0-nullsafety.0 depends on args ^1.4.0, if flutter_launcher_name ^0.0.1 and flutter_launcher_icons any then args ^1.4.0.
And because flutter_appifjoie depends on easy_localization ^3.0.0 which depends on args ^2.0.0, flutter_launcher_name ^0.0.1 is incompatible with flutter_launcher_icons.
So, because flutter_appifjoie depends on both flutter_launcher_name ^0.0.1 and flutter_launcher_icons any, version solving failed.
pub get failed (1; So, because flutter_appifjoie depends on both flutter_launcher_name ^0.0.1 and flutter_launcher_icons any, version solving failed.)

 

1 شخص أعجب بهذا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0
بتاريخ 2 دقائق مضت قال بلال زيادة:

يمكنك تجربة وضع any مرة أخرى لأي حزمة، أو تأكد من أن لديك sdk flutter 2

هو من فتره انا ارغب بالانتقال الى فلاتر 2 ولكن متردد علشان توافق الحزم ولكن لما رغبت ارفع المشروع لك الثاني الذي في السوال المختلف وجدت الفرصه للقيام بذلك لنني سوف اكون مجبور بعد فتره على الانتقال الامر الان نجح على ما يبدو ان المشكله في حزمة ايقونة التطبيق فقط قمت بايقافها الى اشعار لاحق لا توجد مشكله واصبح المكاتب متوافقه جميعها 

 

مع العلم انني قمت بتجربة وضع any 

تمّ تعديل بواسطة مروان مروان3
1 شخص أعجب بهذا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0
بتاريخ 1 دقيقة مضت قال بلال زيادة:

يجب الأنتقال إلى flutter 2 .

نعم الامر افضل فيه مشقه قليلا بسبب حجم التطبيق وكثرت المكتبات المستعمله ولكن الامر جيد في النهايه ويقدم تجربه ممتازه للمستخدم

1 شخص أعجب بهذا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية

يجب أن تكون عضوًا لدينا لتتمكّن من التعليق

انشاء حساب جديد

يستغرق التسجيل بضع ثوان فقط


سجّل حسابًا جديدًا

تسجيل الدخول

تملك حسابا مسجّلا بالفعل؟


سجّل دخولك الآن