• 0

كيف أتجاوز هذا الخطأ على منصة Heroku؟

لم أصادف أي خطأ، لكن عند فتح heroku بـ heroku open المتصفح يُظهر :

 

"We're sorry, but something went wrong."

رابط المشروع:

https://github.com/codelearner777/blog

budi@Lenovo:~/blog$ heroku create
Creating rocky-badlands-5818... done, stack is cedar-14
https://rocky-badlands-5818.herokuapp.com/ | https://git.heroku.com/rocky-badlands-5818.git
Git remote heroku added
budi@Lenovo:~/blog$ git push heroku master
Counting objects: 139, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (98/98), done.
Writing objects: 100% (139/139), 26.23 KiB | 0 bytes/s, done.
Total 139 (delta 31), reused 139 (delta 31)
remote: Compressing source files... done.
remote: Building source:
remote: 
remote: -----> Ruby app detected
remote: -----> Compiling Ruby/Rails
remote: -----> Using Ruby version: ruby-2.2.3
remote: -----> Installing dependencies using bundler 1.9.7
remote:        Running: bundle install --without development:test --path vendor/bundle --binstubs vendor/bundle/bin -j4 --deployment
remote:        Fetching gem metadata from https://rubygems.org/...........
remote:        Fetching version metadata from https://rubygems.org/...
remote:        Fetching dependency metadata from https://rubygems.org/..
remote:        Using rake 10.4.2
remote:        Installing minitest 5.8.2
remote:        Installing i18n 0.7.0
remote:        Installing thread_safe 0.3.5
remote:        Installing builder 3.2.2
remote:        Installing mini_portile 0.6.2
remote:        Installing erubis 2.7.0
remote:        Installing rack 1.6.4
remote:        Installing mime-types 2.6.2
remote:        Installing json 1.8.3
remote:        Installing arel 6.0.3
remote:        Installing coffee-script-source 1.9.1.1
remote:        Installing execjs 2.6.0
remote:        Installing thor 0.19.1
remote:        Installing multi_json 1.11.2
remote:        Using bundler 1.9.7
remote:        Installing rails_serve_static_assets 0.0.4
remote:        Installing bcrypt 3.1.10
remote:        Using rdoc 4.2.0
remote:        Installing sass 3.4.19
remote:        Installing rails_stdout_logging 0.0.4
remote:        Installing tzinfo 1.2.2
remote:        Installing tilt 2.0.1
remote:        Installing rack-test 0.6.3
remote:        Installing sprockets 3.4.0
remote:        Installing mail 2.6.3
remote:        Installing coffee-script 2.4.1
remote:        Installing uglifier 2.7.2
remote:        Installing sdoc 0.4.1
remote:        Installing rails_12factor 0.0.3
remote:        Installing activesupport 4.2.4
remote:        Installing rails-deprecated_sanitizer 1.0.3
remote:        Installing globalid 0.3.6
remote:        Installing activemodel 4.2.4
remote:        Installing jbuilder 2.3.2
remote:        Installing activejob 4.2.4
remote:        Installing activerecord 4.2.4
remote:        Installing pg 0.18.3
remote:        Installing nokogiri 1.6.6.2
remote:        Installing loofah 2.0.3
remote:        Installing rails-dom-testing 1.0.7
remote:        Installing rails-html-sanitizer 1.0.2
remote:        Installing actionview 4.2.4
remote:        Installing actionpack 4.2.4
remote:        Installing actionmailer 4.2.4
remote:        Installing sprockets-rails 2.3.3
remote:        Installing railties 4.2.4
remote:        Installing coffee-rails 4.1.0
remote:        Installing jquery-rails 4.0.5
remote:        Installing rails 4.2.4
remote:        Installing sass-rails 5.0.4
remote:        Installing turbolinks 2.5.3
remote:        Bundle complete! 15 Gemfile dependencies, 52 gems now installed.
remote:        Gems in the groups development and test were not installed.
remote:        Bundled gems are installed into ./vendor/bundle.
remote:        Bundle completed (25.95s)
remote:        Cleaning up the bundler cache.
remote: -----> Preparing app for Rails asset pipeline
remote:        Running: rake assets:precompile
remote:        I, [2015-11-06T07:11:59.545861 #1061]  INFO -- : Writing /tmp/build_3696c7b0356812fdd8d08d263aa37657/public/assets/application-51bf096d402cefc1025d96872785d4cf537dbf0073f5dba9572ac26b890c09ae.js
remote:        I, [2015-11-06T07:11:59.560330 #1061]  INFO -- : Writing /tmp/build_3696c7b0356812fdd8d08d263aa37657/public/assets/application-e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855.css
remote:        Asset precompilation completed (3.72s)
remote:        Cleaning assets
remote:        Running: rake assets:clean
remote: 
remote: ###### WARNING:
remote:        No Procfile detected, using the default web server (webrick)
remote:        https://devcenter.heroku.com/articles/ruby-default-web-server
remote: 
remote: -----> Discovering process types
remote:        Procfile declares types -> (none)
remote:        Default types for Ruby  -> console, rake, web, worker
remote: 
remote: -----> Compressing... done, 30.0MB
remote: -----> Launching... done, v5
remote:        https://rocky-badlands-5818.herokuapp.com/ deployed to Heroku
remote: 
remote: Verifying deploy... done.
To https://git.heroku.com/rocky-badlands-5818.git
 * [new branch]      master -> master
budi@Lenovo:~/blog$ heroku open
Opening rocky-badlands-5818... done

(process:16901): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

كيف يمكنني تجاوزهذا الخطأ؟

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة

يجب أن تكون عضوًا لدينا لتتمكّن من التعليق

انشاء حساب جديد

يستغرق التسجيل بضع ثوان فقط


سجّل حسابًا جديدًا

تسجيل الدخول

تملك حسابا مسجّلا بالفعل؟


سجّل دخولك الآن