• 0

كيف أثبت Rails 4 على Ubuntu؟

أريد العمل على إطار العمل RubyOnRails4، وقد حاولت من عدة مصادر لكن لم أفلح؟ أشتغل على Ubuntu، فهل من مساعدة؟

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
  • 0

الخطوات التالية كفيلة بجعلك تثبت Rails4 على Ubuntu:

  • تثبيت Ruby: حيث أن Ruby هي اللغة التي تبرمج بها التطبيقات على Rails.
sudo apt-get update
sudo apt-get install git-core curl zlib1g-dev build-essential libssl-dev libreadline-dev libyaml-dev libsqlite3-dev sqlite3 libxml2-dev libxslt1-dev libcurl4-openssl-dev python-software-properties libffi-dev
  • بعد ذلك نستعمل RVM :
sudo apt-get install libgdbm-dev libncurses5-dev automake libtool bison libffi-dev
curl -L https://get.rvm.io | bash -s stable
source ~/.rvm/scripts/rvm
rvm install 2.2.3
rvm use 2.2.3 --default
ruby -v
  • ثم RubyGem:
echo "gem: --no-ri --no-rdoc" > ~/.gemrc
gem install bundler

ثم تثبت NodeJs لأنه ضروري لعمل Rails:

sudo add-apt-repository ppa:chris-lea/node.js
sudo apt-get update
sudo apt-get install nodejs
  • ثم:
gem install rails -v 4.2.4
  • نستعمل الأمر للتأكد من تثبيت Rails:
rails -vسنتعمل
# Rails 4.2.4

وهكذا يكون Rails قد ثبتت بنجاح.

Setup Ruby On Rails on Ubuntu 15.04

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة

يجب أن تكون عضوًا لدينا لتتمكّن من التعليق

انشاء حساب جديد

يستغرق التسجيل بضع ثوان فقط


سجّل حسابًا جديدًا

تسجيل الدخول

تملك حسابا مسجّلا بالفعل؟


سجّل دخولك الآن