• 0

رفع مشروع لارافيل على cpanel

مرحبا,

ليس لدي خبرة في التعامل مع cpanel و احاول رفع مشروع لارافيل, لدي مشكلة انه بعد رفع المشروع تظهر صفحة فارغة في الموقع,

ما قمت به هو انشاء مجلد "sites" بجانب المجلد "public_html" و وضعت فيه كل ملفات لارافيل ماعدى الملف public,

في المجلد "public_html" نسخت ملفات public و عدلت في الملف index.php بهذه الطريقة

index.thumb.png.bcbf97162629682bff88ede2971aec1a.png

اين الخلل؟ وشكرا لكم.

 

1 شخص أعجب بهذا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0

إن كانت ملفات لارافل في مجلد sites موجودة في مجلد آخر يجب تضمينه في المسار:

__ DIR__.'/../../sites/myapp-laravel/vendor/autoload.php';
          ^^^^^^^^^^^^^^^^^^^^^^^^^^

require_once __ DIR__.'/../../sites/myapp-laravel/bootstrap/app.php';
                       ^^^^^^^^^^^^^^^^^^^^^^^^^^^

تأكد من ذلك

1 شخص أعجب بهذا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0
بتاريخ 2 دقائق مضت قال Wael Aljamal:

إن كانت ملفات لارافل في مجلد sites موجودة في مجلد آخر يجب تضمينه في المسار:


__ DIR__.'/../../sites/myapp-laravel/vendor/autoload.php';
          ^^^^^^^^^^^^^^^^^^^^^^^^^^

require_once __ DIR__.'/../../sites/myapp-laravel/bootstrap/app.php';
                       ^^^^^^^^^^^^^^^^^^^^^^^^^^^

تأكد من ذلك

لا ليست في مجلد أخرsite.thumb.png.9436574a4ce7ee0c66cda3964da66414.png

بتاريخ 9 دقائق مضت قال Wael Aljamal:

إن كانت ملفات لارافل في مجلد sites موجودة في مجلد آخر يجب تضمينه في المسار:


__ DIR__.'/../../sites/myapp-laravel/vendor/autoload.php';
          ^^^^^^^^^^^^^^^^^^^^^^^^^^

require_once __ DIR__.'/../../sites/myapp-laravel/bootstrap/app.php';
                       ^^^^^^^^^^^^^^^^^^^^^^^^^^^

تأكد من ذلك

في المسار ايهم صحيح:

هل تكون بهذا الشكل 
/../../

require __DIR__.'/../../sites/vendor/autoload.php';

ام بهذا الشكل

/../
require __DIR__.'/../sites/vendor/autoload.php';

 

لانه الان بعد بتحويل المسارات الى :

 


require __DIR__.'/../../sites/vendor/autoload.php';

ظهر هذا الخطأ في الكونسول: Internal Server Error 500


 

site3.thumb.png.0167d27e560853a245025583bd2f81c5.png

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0

اسهل طريقه ان تترك كل ملف فب مكانه و تقوم بوضع جميع ملفات المشروع في public_html ثم تقوم بانشاء ملف جديد htaccess. داخل المجلد public_html وتضع به هذا الكود 

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule ^(.*)$ public/$1 [L]
</IfModule>

ملحوظه اذا لم يظهر هذا الملف يمكنك الضغط علي setting اعلي اليمين ثم اختار show hidden files

1 شخص أعجب بهذا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0
بتاريخ 7 دقائق مضت قال اسماعيل صدوقي:

لا ليست في مجلد أخر

يفترض أن تبقي على المجلد public لنستطيع التحكم بإعادة التوجيه عليه. وملف htaccess إن لم يكن موجود لديك ضع التالي

.htaccess

=>

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteRule ^(.*)$ public/$1 [L]
</IfModule>
  • ليس شرطأ أيضا أن تنقل المفات لمجلد منفضل

تأكد من ربط التخزين

php artisan storage:link

 

1 شخص أعجب بهذا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0
بتاريخ 28 دقائق مضت قال اسماعيل صدوقي:

في المسار ايهم صحيح:


هل تكون بهذا الشكل 
/../../

require __DIR__.'/../../sites/vendor/autoload.php';

ام بهذا الشكل

/../
require __DIR__.'/../sites/vendor/autoload.php';

حسب هيكلية الملفات الصواب هو:

require __DIR__.'/../sites/vendor/autoload.php';

أعتقد أن المشكلة لديك إما في ملف htaccess. لم يتم نسخه إلى مجلد public_html او في ملفات التخزين المؤقت cache لم يتم حذفها. لإظهار الملفات المخفية من الأعلى ستجد Settings إضغط عليها ثم حدد خيار show hidden files ثم save بعد ذلك تأكد من أن الملف htaccess. موجود بداخل public_html و محتواه مطابق لمحتوى الملف على جهازك.

1 شخص أعجب بهذا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0

شكرا لكم ,لكن للاسف جربت كل الطرق التي ذكرتموها و مزالت تظهر صفحة فارغة

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0
بتاريخ 2 دقائق مضت قال اسماعيل صدوقي:

شكرا لكم ,لكن للاسف جربت كل الطرق التي ذكرتموها و مزالت تظهر صفحة فارغة

للاختبارـ ارفع الملف المضغوط للمجلد public_html وفك الضغط فيه ثم أضف عليه ملف htaccess 

1 شخص أعجب بهذا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0
بتاريخ 33 دقائق مضت قال Wael Aljamal:

للاختبارـ ارفع الملف المضغوط للمجلد public_html وفك الضغط فيه ثم أضف عليه ملف htaccess 

انحلت المشكلة, السبب كان أنه عندما اضفت قاعدة البيانات في الملف env, بالغلط تركت مسافة بين حرفين,

اجاباتكم كانت كافية لسؤالي واكتسبت بعض المعرفة التي ممكن ان تفيدني مستقبلا,

شكرا لكم

2 اشخاص أعجبوا بهذا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0
بتاريخ 2 دقائق مضت قال اسماعيل صدوقي:

انحلت المشكلة, السبب كان أنه عندما اضفت قاعدة البيانات في الملف env, بالغلط تركت مسافة بين حرفين,

اجاباتكم كانت كافية لسؤالي واكتسبت بعض المعرفة التي ممكن ان تفيدني مستقبلا,

شكرا لكم

دائما عند رفع المشروع قم بتفعيل خاصية APP_DEBUG في ملف env. حتى إذا ما ظهرت أخطاء تظهر لك رسائل أخطاء تفيدك في حل المشاكل و بعد التأكد من حل جميع المشاكل و عمل الموقع قم بإعادة إلغاء خاصية APP_DEBUG.

بالتوفيق.

2 اشخاص أعجبوا بهذا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية
  • 0
بتاريخ 57 دقائق مضت قال اسماعيل صدوقي:

و مزالت تظهر صفحة فارغة

هنا كان من الأفضل تحديد هل الصفحة فارغة بدون أي HTML أم بدون بيانات؟ 

بعد رفع المشروع على الاستضافة يمكن الإبقاء على :

APP_DEBUG=true

لتظهر الأخطاء، مع إمكانية تثبيت مكتبات مثل barryvdh/laravel-debugbar لأنها توضح المشاكل من خلال واجهات مرئية

2 اشخاص أعجبوا بهذا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
شارك على الشبكات الإجتماعية

يجب أن تكون عضوًا لدينا لتتمكّن من التعليق

انشاء حساب جديد

يستغرق التسجيل بضع ثوان فقط


سجّل حسابًا جديدًا

تسجيل الدخول

تملك حسابا مسجّلا بالفعل؟


سجّل دخولك الآن