Assalamo Alaikoum;

 I have a problem about FireBase, whene I want to run or Debug my app to verify if firebase run correctly the terminal or the debug give an error : 


FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':app:checkDebugAarMetadata'.
> Could not resolve all files for configuration ':app:debugRuntimeClasspath'.
   > Could not find com.google.firebase:firebase-analytics:.
     Required by:
         project :app

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

BUILD FAILED in 3m 2s
Exception: Gradle task assembleDebug failed with exit code 1

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
  • 1

عندما تريد دمج Firebase في تطبيقك ، يجب عليك اختيار إحدى طريقتين الموجودة في التوثيق الرسمي

يمكنك إما اختيار استخدام إصدارات محددة من كل تبعية ، مثل هذا:

implementation 'com.google.firebase:firebase-analytics:18.0.0'
implementation 'com.google.firebase:firebase-firestore:22.0.0'

أو يمكنك استخدام Firebase BoM لاختيارها لك ، بناءً على إصدار BoM واحد يطبق إصدارات متوافقة معينة من أجلك:

//  bom إستيراد إصدار 
implementation platform('com.google.firebase:firebase-bom:26.1.0')

// يتم اختيار إصدارات Firebase SDK تلقائيًا بواسطة BoM
implementation 'com.google.firebase:firebase-analytics'
implementation 'com.google.firebase:firebase-firestore'

 يمكنك العثور على مزيد من المعلومات حول إصدارات Firebase من هنا

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة

يجب أن تكون عضوًا لدينا لتتمكّن من التعليق

انشاء حساب جديد

يستغرق التسجيل بضع ثوان فقط


سجّل حسابًا جديدًا

تسجيل الدخول

تملك حسابا مسجّلا بالفعل؟


سجّل دخولك الآن