• 0

كيف أعالج مشكلة انتقال المتصفح من موقعي المحلي إلى ملف Xampp ؟

أواجه مشكل انتقال الصفحة إلى صفحة Xampp عند إدراج عنوان موقعي المحلي على المتصفح، ورغم قيامي بالإعدادات المبينة أسفله وإعادة تشغيل السيرفرالمحلي لكن دون جدوى:

127.0.0.1   mysite.local

 قمت بتعديل ملف extra/httpd-vhosts.conf :

NameVirtualHost localhost:80
<VirtualHost localhost:80>
ServerName localhost
DocumentRoot "/Applications/XAMPP/xamppfiles/htdocs"
<Directory "/Applications/XAMPP/xamppfiles/htdocs">
  Options Indexes FollowSymLinks MultiViews
   AllowOverride all
       Order Deny,Allow
       Allow from all
</Directory>
</VirtualHost>

<VirtualHost localhost:80>
<Directory "/Applications/XAMPP/xamppfiles/htdocs/wd">
   Options Indexes FollowSymLinks MultiViews
   AllowOverride all
       Order Deny,Allow
       Allow from all
</Directory>
    DocumentRoot "/Applications/XAMPP/xamppfiles/htdocs/wd"
    ServerName mysite.local
</VirtualHost>

ما هو الحل رجاء؟

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
  • 0

المشكل الأساسي هنا هو أن apach لا يتعرف على VirtualHost الجديد، بمعنى آخر يتوجب عليك إضافة مسار موقعك على الحاسوب ضمن لائحة virtualhosts، وذلك بتحرير ملف  http.conf بهذا الشكل:

# Your great site!
<Directory "/Applications/XAMPP/xamppfiles/htdocs/wd">
  Options Indexes FollowSymLinks Includes ExecCGI
  AllowOverride All
  Order allow,deny
  Allow from all
</Directory>

الآن يمكنك الولوج إلى رابط الموقع على السيرفر المحلي دون تكرار خطأ الانتقال إلى XAMPP ، لكن من الممكن أن يحدث خطأ أثناء قراءة ملف index الخاص بالموقع وذلك بسبب عدم وجود الصلاحيات الكافية لقراءته، أي أنه محمي من القراء والكتابة، حينئذ عليك بالأمر التالي:

RewriteEngine On
RewriteBase /
RewriteRule ^.*$ public/index.php [NC,L]

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة

يجب أن تكون عضوًا لدينا لتتمكّن من التعليق

انشاء حساب جديد

يستغرق التسجيل بضع ثوان فقط


سجّل حسابًا جديدًا

تسجيل الدخول

تملك حسابا مسجّلا بالفعل؟


سجّل دخولك الآن