• 0

كيف أحل هذه المشكلة مع WebView على نسخة أندرويد جلي بين؟

قمت بتصميم صفحة ويب للعمل داخل WebView باستخدام HTML وCSS وجافا سكربت فعملت بشكل جيد على إصدارات أندرويد الحديثة لكنها لم تعمل جيدًا على الإصدارات القديمة مثل جلي بين، فما السبب؟

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
  • 0

توجد عدة أسباب لهذه المشاكل من أبرزها:

  • قد يكون السبب اختلاف في حجم الشاشة بين الهواتف، فهل أنت متأكد من أنك صممت الصفحات Responsive Design؟
  • توجد العديد من الثغرات الأمنية في WebView على اصدار جلي بين، فهل متأكد من أنك لم تعطل الجافا سكربت أو ما شابه على هاتفك؟
  • تغيّرت عدة أشياء في الإصدارات الحديثة من WebView فتأكد من أنه لا توجد اختلافات في أسماء ووظائف الدوال والأصناف في هذه النسخة.

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة
  • 0

موقع caniuse هو ماتحتاجه بالضبط، فبالنظر إلى الاصدار القديم، يتيح الموقع التأكد من دعم المتصفحات لإصدار معين، وبالتالي ترى إمكانية عمل webView على Jelly bean.

 من خلال البحث اتضح أن Jelly bean لا تدعم webView باستخدام html و css وخاصة الاصدارات القديمة.

المصادر:

انشر على الشّبكات الاجتماعية


رابط هذه المساهمة

يجب أن تكون عضوًا لدينا لتتمكّن من التعليق

انشاء حساب جديد

يستغرق التسجيل بضع ثوان فقط


سجّل حسابًا جديدًا

تسجيل الدخول

تملك حسابا مسجّلا بالفعل؟


سجّل دخولك الآن