Ali Khadra2

الأعضاء
  • المساهمات

    42
  • تاريخ الانضمام

  • تاريخ آخر زيارة

السُّمعة بالموقع

44 Excellent
  1. لماذا لا يعمل كود ال jquery هنا ؟! وكيف نحل مشكلة عدم توافق الاصدارات بين بعضها ضمن المشروع ؟ هذه اصدارات الحزم عندي من package.json: "expose-loader": "^2.0.0", "jquery": "^3.6.0", "webpack": "^5.35.0", وهذا سطر الاستدعاء من ملف index.js: import 'jquery/dist/jquery.min'; وهذا تضمينه داخل webpack.config.js: { test: require.resolve('jquery'), loader: 'expose-loader', options: { exposes: ['$', 'jquery', 'jQuery'], } }, وهذا هو الكود الذي لم يعمل : $(function () { $('.add-to-cart-btn').on("click", function () { alert('أضيف المُنتج إلى السلة'); }); });