dhtarek

الأعضاء
  • المساهمات

    12
  • تاريخ الانضمام

  • تاريخ آخر زيارة

  • Days Won

    1

السُّمعة بالموقع

7 Neutral
  1. السلام عليكم ورحمة الله أنصحك كمبتدئ البدء أولا في تعلم البرمجة بصفة عامة هناك أمور تشترك فيها الويب والتطبيقات سطح المكتب .. يمكن القول أن الويب أسهل لكنك ستكون دائما في عملية نسخ ولصق وإذا احتجت برمجة وظيفة ما سوف تتوقف تماما لذلك يجب عليك اتباع الخطوات التالية: *الخطوة الأولى: تعلم أولا هيكلة البيانات أو الخوارزميات وهي خطوة لابد منها والتي تتعلم فيها معنى المتغيرات (variables) و العمليات الحسابية البسيطة لتنتقل الى الجمل الشرطية (conditions) والتي تنطبق في حال شرط معين ثم تنتقل إلى التكرارات (loops) في الخوارزميات وتتدرب قليلاً على تطبيق بعض التمارين. أثناء دراستك للخوارزميات حاول تطبيقها في لغة برمجة وأنا أنصحك هنا ببايثون. المدة : من أسبوع إلى أسبوعين . *الخطوة الثانية: تعلم البرمجة الكائنية التوجه: وهي فلسفة تصميم التطبيقات بطريقة جد منظمة ومفيدة ستساعدك كثيراً في ما بعد في فهم الشيفرات المصدرية لأناس آخرين أو حتى تنظيم عملك الخاص وهنا سوف تتعرف عن معنى الصنف (classes) والكائن (objects) ,وتتعلم مكونات الصنف من متغيرات ودوال خاصة بالصنف ، وعلاقتها في مابعد بالصنف وبعض الطرق المطبقة على الاصناف والكائنات وكيفية التعامل معاه مثل الوراثة و التجريد وغيرها وحاول تطبيق هاته المفاهيم ولا تتعمق كثيراً فيها لكن يكفيك معرفتها. حاول دائما التطبيق بلغة برمجية مع محاولة تطبيق امثلة عملية عن كيفية تصميم التطبيقات * الخطوة الثالثة: قرر اللغة التي ستعمل بها والمجال الذي ستعمل به. هنا قرر ماذا تريد أن تصبح مبرمج ويب ام مبرمج سطح مكتب وأعدك بأنك لن تجد أي مشكلة في أعمالك لأن أي علم مفاتيح وعلم البرمجة مفاتيح في فهم فلسفتها. أتمنى أخي الكريم أن أكون أفدتك في هاته الكلمات عن علم البرمجة لك مني كل التقدير الإحترام
  2. بسم الله الرحمن الرحيم أولا باستعمال الجداول كتابة خوارزمية لاضافة متبرص حاولت التفصيل في الخوارزمية قدر المستطاع وتبسيطها وان لك سؤال في هذا الجواب إسأل أخي الكريم تحياتي الجواب الأول: algorithme insertion :type p : structure num_strajaire : entier nom_strajaire: chaine de caractere pernom_staijaire: chaine de caractere adresse : chaine de caractere moyen: reel fin_structure : variable T:Tableau[1..100] de p s:logique i,n:entier debut s:= vraie tantque (s = faux) faire debut ecrire('entrer un numero enregistrement si vous finir insertion entrer 0 ')//affichage lire(n)//lire si n =0 alors s:= faux sinon debut T[i].num_stajaire := n; // deja entrer par utilisateur ecrire ('enter le nom et prenom et adresse et moyen et chaque entrer appuyer entrer ')// chaque lire(T[i].nom_stajaire); //lire nom lire(T[i].Prenom_stajaire)// lire prenom lire(T[i].Adresse) // lire adresse lire(T[i].moyen)//lire moyen finsi fintantque finalgorithme